OpsHub-012000
Description
When you encounter OpsHub-012000, then the following message appears:
OpsHub-012000: Processing blocked - Processing is already in progress or has failed for the corresponding target entity; this target entity has to be processed first, then you may require retrying failure for this entity <entity_id>
Cause
The reason for this error is presence of a failed event on the same entity from the integration. OpsHub Integration Manager blocking this event for data consistency reasons. For example if integration from system A to system B had started event synchronization and done a partial update in system B and then an event failure came, in such cases if OpsHub Integration Manager allows event synchronization for that entity from system B to system A, then it can result into data inconsistency. To prevent data inconsistency OpsHub Integration Manager block such event.
Solution
First resolve the failures on the other way integration for this entity.
To find the integration failures for this entity, you will need entity id from other system that is synchronized with this entity id. To find the entity id, you can use Integration_Sync_Report feature.
Once you found other system entity id, navigate to other way integration failure queue and search that entity id. You can use 'Entity Id' filter for this. For more information on how to apply filter on event failure, refer Filtering failures
Understand the error and resolve this failures.
Now go to integration for which this error came, retry the failure by clicking 'Retry All With Dependents' failure option. For more information on how to retry failed event, refer Action-on-failures
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